Slower Processing Time - CS2 Update

Incident Report for Allstar Gaming

Resolved

We have identified and resolved the issue that was causing clips to process slower than usual. Thank you for your patience!
Posted May 24, 2024 - 10:55 UTC

Monitoring

Since the latest CS2 update, we are experiencing slower processing times for content. Thank you for your patience while we work to optimize our performance!
Posted May 24, 2024 - 02:22 UTC
This incident affected: Clipping (Clipping - CS2).