CS2 Clipping Degradation

Incident Report for Allstar Gaming

Resolved

This issue has been resolved. Thank you for your patience!
Posted Aug 15, 2025 - 18:26 UTC

Identified

Recent updates to CS2 are impacting our ability to make clips in a timely fashion. We are working on a fix to get back to full capacity.

In the meantime, some CS2 in-game effects, cameras and cosmetics are temporarily disabled. We will update this status as more info becomes available.
Posted Aug 14, 2025 - 23:48 UTC
This incident affected: Clipping (Clipping - CS2).