CS2 Clipping Degraded

Incident Report for Allstar Gaming

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 12:07 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 15, 2025 - 17:36 UTC

Monitoring

We've implemented some fixes and are monitoring the situation.
Posted Oct 15, 2025 - 15:40 UTC

Identified

We're aware of issues relating to CS2 clipping. Recent CS2 updates have introduced certain incompatibilities that we've identified and for which we are researching resolutions.
Posted Oct 15, 2025 - 03:47 UTC
This incident affected: Clipping (Clipping - CS2).