Degraded Site Experience (AWS)

Incident Report for Allstar Gaming

Resolved

This issue has been resolved. Thank you for your patience! If you are still running into issues, feel free to reach out to our team at support@allstar.gg.
Posted Oct 21, 2025 - 15:32 UTC

Monitoring

We are actively recovering from the AWS outage and will continue to montior the health of our infrastructure. Thank you for your patience during this time!
Posted Oct 20, 2025 - 19:36 UTC

Identified

We are currently experiencing service disruptions due to an ongoing AWS (Amazon Web Services) outage affecting our infrastructure. As a result, some users may encounter issues with accessing or using our services.
Posted Oct 20, 2025 - 15:13 UTC
This incident affected: Allstar.GG Web Platform.