CS2 Clipping Partial Restoration

Incident Report for Allstar Gaming

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 14:41 UTC

Update

CS2 clipping is back online with limited functionality, some errors and higher than usual wait times. We will continue to update this status as things improve.
Posted Jul 30, 2025 - 00:07 UTC

Monitoring

CS2 clipping is back online with limited functionality, some errors and higher than usual wait times. We will continue to update this status as things improve.
Posted Jul 29, 2025 - 22:44 UTC

Investigating

Due to an unexpected game update, CS2 clipping is currently severely degraded. We are working on a fix, but don’t have an estimate on when services will be fully restored. We appreciate your patience while we work to get back online!
Posted Jul 29, 2025 - 01:11 UTC
This incident affected: Clipping (Clipping - CS2).