Site Usability Outage

Incident Report for Allstar Gaming

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 15:40 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 02, 2025 - 15:40 UTC

Identified

We have identified an issue that is causing issues with logging in and using allstar.gg. You may experience issues until this is resolved. Thank you for your patience!
Posted Jun 02, 2025 - 13:38 UTC
This incident affected: Allstar.GG Web Platform.