CS2 Clipping Delayed

Incident Report for Allstar Gaming

Resolved

This issue has been resolved and any clips that were created during this outage are reprocessing. Thank you for your patience!
Posted May 01, 2024 - 12:09 UTC

Identified

Due to the latest CS2 update, clipping has been delayed. We are working quickly to resolve this issue. Thank you for your patience!
Posted Apr 30, 2024 - 23:36 UTC
This incident affected: Clipping (Clipping - CS2).