CS2 Clipping Delayed

Incident Report for Allstar Gaming

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 16:08 UTC

Monitoring

We're making progress on the backlog and continue to monitor the situation.
Posted Nov 11, 2025 - 14:00 UTC

Identified

Clipping for CS2 is delayed while network providers resolve connectivity issues.
Posted Nov 10, 2025 - 23:07 UTC
This incident affected: Clipping (Clipping - CS2).