Missing Moments

Incident Report for Allstar Gaming

Resolved

Thank you for your patience while we resolved our missing moments issue! If you have missing moments from the past 48 hours, this issue should now be resolved. Check your matches that were affected during the outage to grab your moments. If you have any questions or issues, reach out to our support team.
Posted Feb 26, 2025 - 18:03 UTC

Identified

We're aware that users are experiencing issues with missing moments in Match History from last night & this morning and an update is in progress. It may be several more hours before functionality is fully restored. We appreciate your patience and please check back here for more updates.
Posted Feb 25, 2025 - 16:56 UTC
This incident affected: Match Storage.