CS2 Clipping Degraded

Incident Report for Allstar Gaming

Resolved

This incident has been resolved.
Posted May 08, 2025 - 12:07 UTC

Identified

The recent CS2 update has proven problematic; we've implemented a partial work-around and are seeing better clip throughput currently. We're still pursuing a more robust solution and will continue to update this incident with progress.
Posted May 08, 2025 - 03:34 UTC

Investigating

We are investigating an issue with CS2 clipping; some clips may take longer to be available as we diagnose and resolve the issue.
Posted May 08, 2025 - 01:06 UTC
This incident affected: Clipping (Clipping - CS2).